• UAH
  • USD
  • RUB
  • EUR
  • +38(044) 392-74-33  Киев
  • +38(057) 728-39-00  Харьков
  • +38(056) 794-38-31  Днепр
  • +38(032) 229-58-93  Львов
  • +38(048) 738-57-70  Одесса
  • +38(093) 449-04-21  Life
  • +38(067) 400-88-44  Киевстар
  • +38(095) 630-90-82  MTC
  • +1(888)393-24-51  USA, Toll free
  • +44(131)507-01-14  Great Britain
  • +7(499) 348-28-61  Москва

MySQL. BIT Virtuemart Product Badges

Форумы MySQL BIT Virtuemart Product Badges
rasprodajaua
7 месяцев назад
хостинг: нет
домен: нет
BIT Virtuemart Product Badges
Текст ошибки
1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '2155)' at line 1


Код из-за которого ошибка <?php $_SESSION['badges_in_use']=true ?>
<div style="display:none;" id="<?php echo $product->virtuemart_product_id ?>_bvmpb_mod" class="product_badge"></div>

Как сделать, чтоб все работало? Помогите новичку!
Евгений В.
7 месяцев назад
хостинг: есть
домен: нет
Судя по ошибке - в базу выполняется некий sql-запрос в котором содержится ошибка. А привели Вы - кусок из какого-то шаблона или скрипта.
Поэтому тут важно понять - какой запрос выполнялся к базе при возникновении ошибки.
Сделать это можно или уточнив вопрос у автора BIT Virtuemart Product Badges, by Barg-IT - Joomla Extension Directory , или проанализировав код самостоятельно и либо сохранять его в файл, или вывести на странице.
rasprodajaua
7 месяцев назад
хостинг: нет
домен: нет
На Open Server v5.2.2 (локальный хостинг) все нормально работает, а на данном хостинге нет. Это может быть связано с версией Mysql предоставляемой хостингом?
Евгений В.
7 месяцев назад
хостинг: есть
домен: нет
Вполне может быть и такое. Какая версия используется локально?
rasprodajaua
7 месяцев назад
хостинг: нет
домен: нет
Mysql 5.6
Прикрепленные файлы:
Евгений В.
7 месяцев назад
хостинг: есть
домен: нет
Mysql 5.6 © rasprodajaua

В аккаунте где размещен сайт базы размещены на сервере с mysql 5.7. Думаю, имеет смысл уточнить у автора, поддерживается ли модулем актуальная версия MySQL. Если нет, то через Техническая поддержка клиентов можно обратиться в техническую поддержку для переноса баз на сервер с mysql 5.6
Также судя по скриншоту стоит в "Мои сайты" -- "Настройка php" установить php 7.0.
rasprodajaua
7 месяцев назад
хостинг: нет
домен: нет
Спасибо, Евгений, буду пробывать
rasprodajaua
7 месяцев назад
хостинг: нет
домен: нет
проблема решена! Дело было не в mysql , а в правильной настройке поля ID товара
Участвовать в общении на этом форуме могут только
зарегистрированные пользователи.

Если вы уже зарегистрированы Вам необходимо войти на форум.

Горячая линия
(044)
392 74 33
другие города