CMS Drupal. Друпал 8. Настройки доверенного хоста

audit01
6 лет
0

Здравствуйте! Помогите пожалуйста настроить переменную trusted_host_patterns в settings.php. После установки Друпал 8 на OpenServer в отчете о состоянии написано: В settings.php не настроена переменная trusted_host_patterns. Это потенциальная угроза безопасности вашего сайта. Крайне рекомендуется настроить этот параметр. Более подробная информация доступна на странице Защита против HTTP HOST Header атак.
После гугления нашла следующее: Нужно просто добавить настройки trusted_host_patterns в settings.php вашего сайта:
/sites/default/settings.php

$settings['trusted_host_patterns'] = array(
'^www\.example\.com$',
'^example\.com$',
);
Где вместо example имя вашего сайта.

ЧТО СДЕЛАЛА Я:
* For example:
* @code
*/ $settings['trusted_host_patterns'] = array(
'^http\.auditing\.com\.ua$',
);
/* @endcode

* For example:
* @code
*/ $settings['trusted_host_patterns'] = array(
'^auditing\.com\.ua$',
'^.+\.auditing\.com\.ua$',
'^auditing\.com\.ua$',
'^.+\.auditing\.com\.ua$',
);
/* @endcode

После чистки кеша отчет о состоянии выдал следующее: Настройки доверенного хоста Включено
Переменная trusted_host_patterns выставлена в режим разрешения ^auditing\.com\.ua$, ^.+\.auditing\.com\.ua$, ^auditing\.com\.ua$, ^.+\.auditing\.com\.ua$

ПРАВИЛЬНО ЛИ Я СДЕЛАЛА?

toxi
6 лет
2

Эту строку

* For example:
* @code
*/ $settings['trusted_host_patterns'] = array(
'^http\.auditing\.com\.ua$',
);
/* @endcode

лучше изменить так
* For example:
* @code
*/ $settings['trusted_host_patterns'] = array(
'^auditing\.com\.ua$',
);
/* @endcode

То есть указать адрес сайта без http

После чистки кеша отчет о состоянии выдал следующее: Настройки доверенного хоста Включено
Переменная trusted_host_patterns выставлена в режим разрешения ^auditing\.com\.ua$, ^.+\.auditing\.com\.ua$, ^auditing\.com\.ua$, ^.+\.auditing\.com\.ua$
© audit01

Если написано, что настройки доверенного хоста активированы - значит настройку выполнили верно.

audit01
6 лет
1

СПАСИБО

drvadz
3 года
0

Тоже сначала не мог разобраться. Для своего сайта на HTTPS - seohub.pro настроил так:

$settings['trusted_host_patterns'] = array(
'^seohub\.pro$',
'^.+\.seohub\.pro$',
);


Ошибка пропала