Хостинг. Ошибка в файле .htaccess Нужна помощь!

SeoMarik
8 років
0

У меня ошибка 500 я поменял ссылку и не чего! Подскажите что я делаю не так?
Вот он до изменения ссылки!

DirectoryIndex index.php
Options -Indexes
Allow from all
<Files "*.htaccess">
order allow,deny
deny from all
</Files>
<Files ~ "php.ini">
Order allow,deny
Deny from All
</Files>
<Files "*.inc">
order allow,deny
deny from all
</Files>
<Files "*.tpl">
order allow,deny
deny from all
</Files>
<Files ~ "\.(htaccess|htpasswd|inc|dat|ini)$">
Deny from All
</Files>

RemoveHandler .html .htm
AddType application/x-httpd-php .php .htm .html .phtml .inc
AddDefaultCharset utf-8

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php?wtpath=$1&wtquery=%{QUERY_STRING} [L]

ErrorDocument 400 /index.php?section=errordocument&errcode=400
ErrorDocument 401 /index.php?section=errordocument&errcode=401
ErrorDocument 403 /index.php?section=errordocument&errcode=403
ErrorDocument 404 /index.php?section=errordocument&errcode=404

php_flag magic_quotes_gpc 0
php_flag magic_quotes_runtime 0


А вот после того как я заменил её!

DirectoryIndex index.php
Options +SymLinksIfOwnerMatch
Allow from all
<Files "*.htaccess">
order allow,deny
deny from all
</Files>
<Files ~ "php.ini">
Order allow,deny
Deny from All
</Files>
<Files "*.inc">
order allow,deny
deny from all
</Files>
<Files "*.tpl">
order allow,deny
deny from all
</Files>
<Files ~ "\.(htaccess|htpasswd|inc|dat|ini)$">
Deny from All
</Files>

RemoveHandler .html .htm
#AddType application/x-httpd-php .php .htm .html .phtml .inc
AddDefaultCharset utf-8

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php?wtpath=$1&wtquery=%{QUERY_STRING} [L]

ErrorDocument 400 /index.php?section=errordocument&errcode=400
ErrorDocument 401 /index.php?section=errordocument&errcode=401
ErrorDocument 403 /index.php?section=errordocument&errcode=403
ErrorDocument 404 /index.php?section=errordocument&errcode=404

php_flag magic_quotes_gpc 0
php_flag magic_quotes_runtime 0

Подскажите что не так и что я забыл прокомментировать!

Евгений В.
8 років
1

Удалите ( или закомментируйте знаком #)ещё из .htaccess строки:
php_flag magic_quotes_gpc 0
php_flag magic_quotes_runtime 0
и проверьте работу сайта. Если ошибка будет сохраняться - сообщите пожалуйста его адрес для более подробной проверки.

SeoMarik
8 років
0

Спасибо помогло! Спасибо! +1

Тема закрита.