CMS Joomla. Проблема с преходом из флеша - к ссылке добавляется имя сайта.

pro3dlife
10 років
0
На новом хостинге столкнулся с такой проблемой. Я создаю виртуальный туры во флеше. Внутри флеша есть переход по ссылке. Но, почему-то при нажатиина ссылку открывается новое окно не ссылки, а к указанному урл добавляется еще имя моего сайта. Естественно ничего не переходит.
Вот, например виртуальный тур www.vr-photo.com.ua/images/pano/shop/voentorgdici/voentorg_disi.html
И там на лого справа внизу переход на сайт voentorg.org. А фактически вылетает урл www.vr-photo.com.ua/images/pano/shop/voentorgdici/www.voentorg.org и ничего никуда не переходит.

вот строчка из xml
<plugin name="logo4" url="voentorg_disidata/graphics/logo4.png" keep="true" align="rightbottom" x="10" y="10" width="160" height="40" onclick="openurl(www.voentorg.org,_blank)"/>

Подскажите, в чем проблема?
rudenko
10 років
0
Flash выполняется то не на хостинге, а на клиентском компьютере. И подает команду браузеру клиента сделать переход.
Сервер тут участвет только в отдаче swf файла клиенту, без всякой дополнительной обработки.
Тут проблему не в хостинге искать нужно а во flash ролике.
Нужно сделать trace параметра, который передается непосредственно в ролик.
pro3dlife
10 років
0
А как быть с таким моментом - при запуске ролика с компьютера все работает верно- ролик открываю в модзилле, нажимаю на переход и все открывается верно.
А если этот же ролик запускаю с сайта, то получаю неверный переход
rudenko
10 років
0
Такое ощущение, что в качестве параметра передается не www.voentorg.org, а просто www.voentorg.org. Попробуйте вывести отладочную информацию для ролика с указанием строки, которая передается непосредственно в функцию, которая должна открывать новое окно с ссылкой.
pro3dlife
10 років
0
Да нет, все полностью прописываю.
Я вот подумал - может у меня модзилла глючит? Можете попробовать сами сделать переход по ссылке?
rudenko
10 років
0
У меня в chrome под Linux та же проблема.
pro3dlife
10 років
0
если не сложно, попробуйте еще раз проверить
rudenko
10 років
0
О, теперь работает нормально. В новом окне открывает ссылку.
Тема закрита.