CMS Joomla. Решено! Не подсвечиваются пункты и не выпадают подпункты меню с модулем Main menu

yelena.langer
7 років
0
Выяснилось, что на сайте, размещенном на данном хостинге не работает нормально меню с модулем Main menu.
А именно, не подсвечиваются пункты и не выпадают подпункты меню при наведении курсора .

При чем локально (денвер) все работает и другой сайт с этим же шаблоном и такими же настройками и функциями только у другого хостинг провайдера - работает без проблем.

Подскажите, плз, кто сталкивался и в чем может быть причина?
toxi
7 років
0
Возможно пути к нужным файлам проверить нужно. Еще попробуйте почистить кеш браузера. Так же еще проверьте, не за пущен ли в это время Денвер на компьютере, когда вы проверяете сайт на хостинге. (может быть одинаковое имя домена прописано в Денвере и на хостинге).
Выпадающее меню не работает в админке либо на сайте?
yelena.langer
7 років
0
На сайте.
Повторюсь, локально (на денвере) этот же сайт работает как надо. Проблема с меню, только на этом сайте, точнее на данном хостинге.

Сайт с таким же шаблоном, но на другом хостинге со схожими настройками работает без проблем.
Евгений В.
7 років
0
В случае если озвученная причина "А у меня в ХХХ оно работало" первым шагом нужно внимательно проверить - правильно ли перенесен сайт: Как перенести Joomla на хостинг
Потом сверить настройки этого самого ХХХ (денвер, другой хостинг). например из того что сразу бросается в глаза - в комплекте с денвером и на некоторых хостингах идёт PHP 5.3 (устаревшая версия), а на хостинге по-умолчанию используется более свежая 5.4.
Поменяйте вот так: Как сменить версию PHP? на 5.3 или 5.2 и проверьте работу сайта через час. Остальные настройки тоже стоит сверить.

Если будет совсем плохо и вышеперечисленное не поможет - закажите перенос сайта нашими силами cp.ukraine.com.ua/support/transfer/ (но ожидание может занять до 10 дней максимум).
JSemikov
7 років
0
Если будет совсем плохо и вышеперечисленное не поможет - закажите перенос сайта нашими силами © Евгений В.

С Дэнвера перенести проблематично будет ;)
А вообще все вышеописанное - чистый css и работать должен, если на месте сам файл с нужными стилями и на него выставлены верные права.
Неправильно _SERVER["DOCUMENT_ROOT"] определиться не мог, так что наиболее вероятно, что путь к нужному файлу стилей прописан неверно.
rudenko
7 років
0
Выложите на форум ссылку на сайт.
Евгений В.
7 років
0
Выложите на форум ссылку на сайт. © Илья

+1
И, по возможности, пример работающего сайта (для сравнения).
yelena.langer
7 років
0
Сайт на котором не работает:

Где работает: demo.omegatheme.com/joomla25/ot_ishoesbox/ (этот же шаблон используется).

Также, работает локально на Денвере (PHP 5.3.13).

На данный хостинг, сайт перенесен примерно месяц назад, по всем правилам с беспроблемным результатом. При переносе, с одного и того же бекапа был параллельно установлен локально на денвер.

После чего началась работа с сайтом. Конкретно по данному меню, с которым проблема, сначала все настройки были сделаны локально на денвере, а после сделаны такие же на сайте и загружены соответствующие файлы на сервер (css).

По вчерашней рекомендации были испробованы по отдельности версии PHP 5.3 и 5,2, а также применены Стандартные наборы настроек PHP для Joomla 2.5. Результата ничего не дало.

UPD1: Ссылку на сайт, который не работает видно? А то я не вижу в форуме.
Тогда так ссылку дать попробую так: npb(.)in(.)ua
yelena.langer
7 років
0
Вопрос решился.

Был конфликт библиотек jQuery Виртумарта и самой CMS. Решилось отключением Virtuemart jQuery.
Тема закрита.