Акция!  Домен 34 грн, домен 55 грн, домен  - 200 грн домен  - 65 грн, домен  - 99 грн, домен  - 56 грн!, домен  - 425 грн!
Мы используем cookie-файлы
Для оптимизации работы нашего сайта мы используем cookie-файлы. Продолжая использовать сайт, Вы соглашаетесь с использованием cookie-файлов.
  • RUB
  • USD
  • EUR
  • UAH
Чат техподдержки
Вы являетесь клиентом?
  • +38(044) 392-74-33  Киев
  • +38(057) 728-39-00  Харьков
  • +38(056) 794-38-31  Днепр
  • +38(032) 229-58-93  Львов
  • +38(048) 738-57-70  Одесса
  • +38(093) 170-15-42  Life
  • +38(067) 400-88-44  Киевстар
  • +38(095) 630-90-82  MTC
  • +1(888)393-24-51  USA, Toll free
  • +44(131)507-01-14  Great Britain
  • +7(499) 348-28-61  Москва

Пожелания и предложения. Рекомендуемая (стабильная) версия PHP

Форумы Пожелания и предложения Рекомендуемая (стабильная) версия PHP
Bumble
7 месяцев
хостинг: есть
домен: есть
1
Рекомендуемая (стабильная) версия PHP
Приветствую!

Прошу рассмотреть возможность смены рекомендуемой версии PHP.

В текущий момент гуй рекомендует 5.6 (во всяком случае, в моем аккаунте, см. аттач), который уже давно не является основной веткой и не поддерживается сообществом даже на уровне секьюр-фиксов.
Так-то уже пора 7.1 к земельке прикладывать, чтоб привыкал, а тут все еще 5й рекомендуют...

Текущий статус версий можно найти на следующей страничке: PHP: Supported Versions

Давайте бороться за производительность и безопасность вместе!
Добра!

ЗЫ - Если сабж дублирует уже имеющийся - приношу извинения! Беглым поиском не нашел.
Прикрепленные файлы:
dotern
7 месяцев
хостинг: есть
домен: есть
Какая вам разница напротив какой версии будет рекомендация?
Рекомендуют именно 5.6 поскольку существует огромное количество сайтов, владельцы которых прочитают рекомендацию переключить на 7 версию и в следствии получат неработающий сайт. Потом тонны обращений в саппорт, зачем хостингу такое счастье?
Bumble
7 месяцев
хостинг: есть
домен: есть
Какая вам разница напротив какой версии будет рекомендация? © dotern

Мое "пожелание и предложение".

По мне, так такая формулировка - вообще вводит в заблуждение пользователей, создавая вид "нестабильности" более старших веток, в то время как они уже и сами успели "поплавать". Это, в свою очередь, приводит к использованию устаревшего ПО, что отражается на безопасности и статистике текущего хоста, и всего веба.

переключить на 7 версию и в следствии получат неработающий сайт © dotern

А если наоборот? Вероятность увидеть эту "рекомендацию" куда выше при создании нового сайта, чем на работающих (с уже выставленным параметром).
А если сайтец вообще на версии 4 крутится (ну, или там 5.3 какой-нибудь) - не страшно же 5.6 рекомендовать...
Ну, и при развертывании сайтов рассчитанных на, хотя бы, 7.0 - получаем ту же историю.

Даже если получит - отличный мотиватор обновится (или, хоть, узнать о то что обновляться нужно), что, опять же, скажеться на повышении общей безопасности.

тонны обращений в саппорт, зачем хостингу такое счастье? © dotern

Не уверен что, в принципе, должен задумываться о саппорте хостинга.
eugen
7 месяцев
хостинг: есть
домен: есть
2
Обновление дефолтной версии планируется в скором времени
rx8
6 месяцев
хостинг: есть
домен: есть
А если наоборот? Вероятность увидеть эту "рекомендацию" куда выше при создании нового сайта, чем на работающих (с уже выставленным параметром).
А если сайтец вообще на версии 4 крутится (ну, или там 5.3 какой-нибудь) - не страшно же 5.6 рекомендовать...
Ну, и при развертывании сайтов рассчитанных на, хотя бы, 7.0 - получаем ту же историю.
© Bumble


Не верно. Сайт, который чудно работал на версии 5.3, на 5.4 может начать сыпать ошибками, потому что изначально был написан на php 3. Аналогично, всё что чудно работало на php 7.0 при переходе на php 7.2, будет показывать ошибки (актуально для модулей wp).
Те кто не знают какую версию php выбрать, вряд ли смогут быстро разобраться почему раньше всё работало, а теперь перестало. А те кто знает, сами ставят нужную версию под нужные задачи.
Bumble
6 месяцев
хостинг: есть
домен: есть
-2
Не верно © info5

Это у вас не верные доводы. Прям вообще глупости, если честно...

Сайт, который чудно работал на версии 5.3, на 5.4 может начать сыпать ошибками, потому что © info5

Потому что там сломан ряд совместимостей (http://php.net/manual/ru/migration54.incompatible.php), при чем тут php 3 вообще? И где тут 5.6?


всё что чудно работало на php 7.0 при переходе на php 7.2, будет показывать ошибки © info5

Мне очень сложно представить как нужно писать код чтоб он был написан для 7.0 и не работал в 7.2. Это прям намеренное вредительство какое-то. Возможно, разработчики модулей wp специально "оставляют себе фронт работы", чтоб про них "не забывали", так сказать. И, снова, рекомендация 5.6 тут не поможет.


Те кто не знают какую версию php выбрать, вряд ли смогут быстро разобраться почему раньше всё работало, а теперь перестало. А те кто знает, сами ставят нужную версию под нужные задачи. © info5

Еще раз! Рекомендация - она и сейчас есть (5.6), и она ни разу не оправдывает ни один из приведенных вами примеров. Изменение рекомендуемой версии, скорее, для отражения актуальности.
rx8
6 месяцев
хостинг: есть
домен: есть
Мне очень сложно представить как нужно писать код чтоб он был написан для 7.0 и не работал в 7.2 © Bumble


Множество различных CMS написано на версиях php ветки 5. Совместимость таких CMS с веткой 7 есть, но зачастую она не полная или идет с запозданием (баги исправляются с запозданием). И при переносе сайта с одного сервера, где был установлен php с версии php 7.0 и всё работало, на сервер с php 7.2 могут появится ошибки, которые пользователи исправить не смогут / не захотят.

Пример - у пользователя (не программиста) есть свой сайт на WP (или другой CMS) с несколькими модулями, который когда-то написал/настроил программист. Этот сайт обслуживается только пользователем (не программистом), с уровнем от "о, тут появилась кнопка обновить WP и несколько модулей, значит сейчас нажму обновить" и заканчивая тем, что с момента открытия сайта, этот сайт ни разу не обновлялся. А еще есть модули, которые написаны давно и просто уже не поддерживается разработчиком, но они пока продолжают работать, даже после обновления WP, на более свежую версию. И тут ВНЕЗАПНО, приходит его знакомый, любитель всего самого нового и говорит, "а что это у тебя php 7.0 стоит, поставь последний 7.2, тем более, что его даже "хостер рекомендует" и всё у тебя будет работать на 15% быстрее и лучше". Или даже банальный переезд с одного хостинга на другой. В результате, пользователь переключает/переезжает, видит что всё вроде работает, а спустя пару дней узнаёт что у него появилось куча каких-то страшных надписей на сайте или вовсе половина функционала отвалилась из-за не обновляемого модуля. И это становится гемороем для пользователя (он не запомнил, что где-то что-то поменял или не знал что вообще нужно выставлять какую-то там версию php) и для техподдержки хостера, которую этот пользователь начнет терроризировать.

Версия PHP 5.6 выбрана рекомендуемой по причине максимальной минимизации гемороя для пользователя и для уменьшения обращений в техподдержку хостера. Можно было бы конечно поставить 5.2-4, но это в свою очередь, так же увеличит количество обращений типа "ой, всё пропало", и "тут работало, а тут перестало".

Вы предлагаете всем без разбора рекомендовать/ставить самое свежее. А я вам говорю, что самое свежее нужно только для тех, кто знает что с этим делать, и как это исправить, если что-то пошло не так.

Пользователей-программистов, которые знают чем отличается 7.2 от 7.0 в процентном соотношении к остальным пользователям шаред-хостинга ничтожно мало, ведь основная масса пользователей шаред-хостинга это как раз те, кому кто-то что-то настроил и оно как-то работает.

+ ко всему вышеизложенному, CMS написанных исключительно на >= 7.0, без поддержки 5.6 гораздо меньше, чем написанных на <= 5.6, но хоть с какой-то поддержкой >= 7.0.
Bumble
6 месяцев
хостинг: есть
домен: есть
@info5, делитесь статой, что-ле, а то голословных высказываний привели много, а отвечать на них инфы у меня нет...

Я, в целом, свои аргументы привел. Считаю их верными.

Если менять действительно так накладно, с т.з. бизнеса - ок, все понимаю, делайте как лучше вам.
Но прошу, хотя бы формулировку изменить, или сноску-там какую, о том что это не "рекомендуемая, стабильная версия", а что-то вроде "версия, которую МЫ рекомендуем, основываясь на общей статистике хоста, в которой преобладают, преимущественно ленивые бестолочи (это я нарочно перегибаю), несведущие что и как им настраивать, а эта версия подходит для максимального среза подобных аккаунтов - читайте спецификацию инструмента, для которого намереваетесь установить версию, или консультируйтесь со специалистами для достижения соответствующих настроек".

Ну, или возле каждой стабильной версии пишите, что она стабильна. Иначе, по вине вчерашних недоадминов гс'ов, большинство сайтов которых "не поддерживает", остальные такие же вынуждены платиться производительностью и безопасностью.
eugen
6 месяцев
хостинг: есть
домен: есть
2
Здесь с разных сторон можно приводить агрументы и они будут одинаково весомыми. Мы вынуждены несколько консервативно к этому вопросу подходить, но обновление обязательно будет. Вместе с изменением дефолтной версии php на серверах.

PS. Во избежание недоразумений, @info5 не является сотрудником хостинга
Участвовать в общении на этом форуме могут только
зарегистрированные пользователи.

Если вы уже зарегистрированы Вам необходимо войти на форум.