Хостинг. Yii2 ICU =>49.0

info1081
6 лет
1

Возникла проблема с Yii2. Для корректной работы с датами и локализациями необходима версия библиотеки ICU =>49.0, текущая версия на хостинге стоит 4.2.1. На локалке на open server все работает отлично, после переноса на хостинг начались проблемы с отображением дат. В панели управления не нашел способов решить проблему. Подскажите пожалуйста, как обновить CLI или в каком направлении копать хотя бы... очень не хочется писать свои велосипеды для корректного форматирования дат.

inda10
6 лет
0

у меня тоже с yii2 проблемы на этом хостинге: yadi.sk/i/OGMhbFdkdkoBe
как решить? Очевидно дело в некорректно настроенном модуле PHP, который устанавливали администраторы серверов?

inda10
6 лет
0

И присоединяюсь к вопросу топик стартера:

Для корректной работы с датами и локализациями необходима версия библиотеки ICU =>49.0, текущая версия на хостинге стоит 4.2.1. © info1081


Прилагаю вещдок: yadi.sk/i/9cj3rzQ6fvk6Q :)

eugen
6 лет
0

Что касается timezonedb - проверьте, сейчас уже не должен возникать warning.

По поводу версии ICU - мы используем текущую версию из официального репозитория, рассмотрим вариант обновления.

inda10
6 лет
0

Что касается timezonedb - проверьте, сейчас уже не должен возникать warning. © eugen

Вроде больше не возникает. Спасибо.

Тема закрыта.