Для тех, кто не спит!
Скидка -15%
Мы используем cookie-файлы
Для оптимизации работы нашего сайта мы используем cookie-файлы. Продолжая использовать сайт, Вы соглашаетесь с использованием cookie-файлов.
Панель управления
  • Русский
  • Українська
  • UAH
  • USD
  • RUB
  • EUR
  • 0-800-307-307  Горячая линия
  • +38(044) 392-74-33  Киев
  • +38(057) 728-39-00  Харьков
  • +38(056) 794-38-31  Днепр
  • +38(032) 229-58-93  Львов
  • +38(048) 738-57-70  Одесса
  • +38(093) 170-15-42  Life
  • +38(067) 400-88-44  Киевстар
  • +1(888)393-24-51  USA, Toll free
  • +44(131)507-01-14  Great Britain
  • +7(499) 348-28-61  Москва

Хостинг. Проблемы с переносом форума phpBB с сервисного адреса на поддомен


designer3
5 лет
0
Проблемы с переносом форума phpBB с сервисного адреса на поддомен

Здравствуйте.
Я создал форум на phpBB 3.1.5. Так как домен зарегистрирован у другого регистратора, я ждал, пока заработает поддомен и делал форум, используя сервисный адрес.
При доступе к форуму через сервисный адрес проблем нет. Заработал поддомен, решил перенести на него. В админке изменил домен сайта, других изменений, по идее, не требуется. Очистил кэш.
После этого форум работает практически нормально (скрин 1).
Проблема возникает при перезагрузке страницы (F5) - слетают все стили и картинки, остается голый текст (скрин 2). Иногда при перезагрузке остаются видны некоторые картинки (например, шапка или аватары), изредка после перезагрузки снова виден весь форум. При вводе адреса форума в строку адреса браузера снова все видно хорошо, при переходе по внутренним ссылкам форума тоже почти всегда все отображается нормально.
На сервисном адресе все работает хорошо.
В поддержке phpBB ответили "Либо глючит хостинг, либо слетели права на папки или файлы". Не похоже на проблему с правами, т. к. глючило бы и на сервисном адресе.
Подскажите, в чем может быть проблема.
[[upload]forum1.png[[/upload]]
[[upload]forum2.png[[/upload]]

designer3
5 лет
0

Похоже, nginx не отдает нужные файлы.

Евгений В.
5 лет
1

Похоже, nginx не отдает нужные файлы. © designer3

Думаю, всё гораздо проще. Уточните пожалуйста адрес форума?

designer3
5 лет
0

Антей - Главная страница
Доступ к разделам для гостей закрыт, но там и так все видно.
Сервисный адрес:
Антей - Главная страница

toxi
5 лет
1

Попробуйте отключить в админке форума пункт (просто поставьте отметку "НЕТ"):

"Принудительные настройки URL сервера:
Если выбрано, то указанные здесь настройки будут использованы вместо автоматически определённых значений."

Еще попробуйте выполнить:
Очистить все сессии
А так же на вкладке "Стили" - "Шаблоны", выполнить очистку кеша каждого шаблона.

designer3
5 лет
0

Принудительные настройки и так были выключены.
Вкладку, на которой можно очистить кеш шаблона я не нашел :(
А вот очистка сессий, похоже, помогла! Спасибо огромное!

Участвовать в общении на этом форуме могут только зарегистрированные пользователи.