Мы используем cookie-файлы
Для оптимизации работы нашего сайта мы используем cookie-файлы. Продолжая использовать сайт, Вы соглашаетесь с использованием cookie-файлов.
Панель управления
  • Русский
  • Українська
  • UAH
  • USD
  • RUB
  • EUR
  • +38(044) 392-74-33  Киев
  • +38(057) 728-39-00  Харьков
  • +38(056) 794-38-31  Днепр
  • +38(032) 229-58-93  Львов
  • +38(048) 738-57-70  Одесса
  • +38(093) 170-15-42  Life
  • +38(067) 400-88-44  Киевстар
  • +38(095) 630-90-82  Vodafone
  • +1(888)393-24-51  USA, Toll free
  • +44(131)507-01-14  Great Britain
  • +7(499) 348-28-61  Москва

Хостинг. Проблема с редиректом на форуме PHPBB 3 после перехода на HTTPS


max.dieand
6 месяцев
0
Проблема с редиректом на форуме PHPBB 3 после перехода на HTTPS

Была проблема с редиректом после авторизации, через порт 80. Исправил по рекомендациям в посте: https://www.ukraine.com.ua/forum/hosting/Problema-s-forumom-phpbb3-i-http.html
Ситуация описанная в посте - 1 в 1, как у меня, но результат не тот :( после выполнения всех дейсвтий, у меня выдает ошибку ERR_CONNECTION_REFUSED т.к. редирект идет не на поддомен на котором работает форум, forum.xxx.org.ua, а на основной домен xxx.org.ua
Помогите, пожалуйста.
Движок PHPBB 3.1.12

toxi
6 месяцев
0

Проверьте настройки форума по скриншотам ниже.
А так же проверьте .htaccess файл:
<div class='forum-code'><div class="bash" style="font-family:monospace;"><span style="color: #666666; font-style: italic;"># SSL ON</span><br />RewriteCond <span style="color: #000000; font-weight: bold;">%</span><span style="color: #7a0874; font-weight: bold;">{</span>HTTP:SSL<span style="color: #7a0874; font-weight: bold;">}</span> <span style="color: #000000; font-weight: bold;">!</span><span style="color: #000000;">1</span><br />RewriteRule <span style="color: #7a0874; font-weight: bold;">(</span>.<span style="color: #000000; font-weight: bold;">*</span><span style="color: #7a0874; font-weight: bold;">)</span> https:<span style="color: #000000; font-weight: bold;">//%</span><span style="color: #7a0874; font-weight: bold;">{</span>HTTP_HOST<span style="color: #7a0874; font-weight: bold;">}</span><span style="color: #000000; font-weight: bold;">%</span><span style="color: #7a0874; font-weight: bold;">{</span>REQUEST_URI<span style="color: #7a0874; font-weight: bold;">}</span> <span style="color: #7a0874; font-weight: bold;">[</span>QSA,L,<span style="color: #007800;">R</span>=<span style="color: #000000;">301</span><span style="color: #7a0874; font-weight: bold;">]</span><br /><span style="color: #666666; font-style: italic;"># SSL ON</span><br /><br />......</div></div>
В настройках сайта, панели управления хостингом, должна быть ВЫКЛЮЧЕНА передресация с http на https
При таких настройках форум без проблем работает на субдомене по https протоколу.

max.dieand
6 месяцев
0

toxi, спасибо огромное!
Дивным образом, просто после очередного переключения переадресации http->https с Он в ОФФ и обратно, все заработало само по себе. При этом, принудительная настройка URL так же включена.
Вторые сутки полет нормальный.

Участвовать в общении на этом форуме могут только зарегистрированные пользователи.