CMS WordPress. Сайт ддосит на себя

veseliymakler
8 лет
0

Пару недель назад резко увеличилось количество запросов и использование процессорного времени (число посетителей осталось прежним). Техподдержка говорит, что сайт ддосит сам на себя.

Прошу совета, где искать причину и как исправить ситуацию. Сайт - odessapost.com/

ZimbalisT
8 лет
0

Самая распространенная причина такого поведения сайта - это когда при настройке какого то скрипта, компонента или плагина вместо внутреннего пути к файлам сайта вида /home/bla/bla/bla/ указать внешний путь odessapost.com/bla/bla/bla/
Нужно смотреть логи сайта, найти обращения к сайту, содержащие строку hosted by www.ukraine.com.ua и понять, как это можно воспроизвести самому (зайти на определенную страницу или нажать на определенную кнопку на сайте).
А дальше на всякий случай делаем и где то сохраняем полную копию сайта, восстанавливаем тему сайта на умолчания, отключаем все дополнительные плагины сайта и пробуем воспроизвести проблему.
99% за то, что она исчезнет. Тогда по очереди включаем все обратно, после каждого включенного компонента снова пробуем воспроизвести проблему и таким образом находим проблемный компонент.

veseliymakler
8 лет
0

Спасибо. у меня путь к изображениям типа odessapost.com/foto/2014/01/muzey_bleschunova_01.jpg

Надо перебить на /foto/2014/01/muzey_bleschunova_01.jpg
Но таких ссылок несколько тысяч. Вручную убирать долго. Может есть способ в Вордпрессе, как-то автоматически изменить? То есть убрать в каждом пути к изображению odessapost.com

rudenko
8 лет
0

Нет, это не связано с изображениями. Картинки не трогайте.

veseliymakler
8 лет
0

Да нет, похоже это дает вброс. Перебил последние сообщения и сразу пропали дополнительные запросы. Получается, что с открытой страницы вместо внутреннего обращения к файлу с изображением, шел новый запрос к сайту, то есть формировался дополнитнльный запрос.

Спасибо.

ZimbalisT
8 лет
0

Здесь важно найти основную причину, по которой ссылки формируются некорректно. Ищите плагин, связанный с обработкой изображений, вероятно при его настройке Вы указали внешний путь к папке с изображениями, вместо внутреннего. Возможно для устранения проблемы будет достаточно переустановить этот плагин с указанием корректного пути.

veseliymakler
8 лет
0

В том то и беда, что я сам себя перемудрил, и папку с фото создал вручную безо всякого плагина. То есть я изображения загружаю не с помощью сервиса медиафайлов, а вручную. Мне почем-то показалось, что при этом не будут формироваться запросы с админки. Теперь вижу, что я был очень сильно не прав. Причем дважды. теперь придется поработать ручками.

Тема закрыта.