CMS WordPress. Проблема с обновлением Wordpress до новой версии 4.3 Billie

VlastaViktoriya
6 лет
0

Здравствуйте! Обновила свой сайт до новой версии Wordpress 4.3, после чего мне выдало такую ошибку: Notice: Вызванный метод конструктора класса WP_Widget считается устаревшим с версии 4.3.0! Используйте

__construct()
Что делать? Подскажите, пожалуйста!
Адрес сайта: agata.org.ua

Евгений В.
6 лет
0

Видимо какой-то из используемых плагинов (или тема оформления) сильно устарел отстав от самого вордпресса.
Можно просто в файле wp-config.php строку
define('WP_DEBUG', true);
заменить на
define('WP_DEBUG', false);
Это скроет сообщения об ошибках.
Но лучше, конечно найти и отключить/заменить проблемные плагины, так как отключение WP_DEBUG скрывает ошибки, но не устраняет их причину.
Ещё интересный материал по теме:
wp-kama.ru/question/obnovlenie-wp-do-43

VlastaViktoriya
6 лет
0

Спасибо, Евгений! :) Все таки попробую разобраться в чем причина.

Тема закрыта.