Мы используем cookie-файлы
Для оптимизации работы нашего сайта мы используем cookie-файлы. Продолжая использовать сайт, Вы соглашаетесь с использованием cookie-файлов.
  • Русский
  • Українська
  • UAH
  • USD
  • RUB
  • EUR
  • +38(044) 392-74-33  Киев
  • +38(057) 728-39-00  Харьков
  • +38(056) 794-38-31  Днепр
  • +38(032) 229-58-93  Львов
  • +38(048) 738-57-70  Одесса
  • +38(093) 170-15-42  Life
  • +38(067) 400-88-44  Киевстар
  • +38(095) 630-90-82  Vodafone
  • +1(888)393-24-51  USA, Toll free
  • +44(131)507-01-14  Great Britain
  • +7(499) 348-28-61  Москва

CMS Joomla. Проблема с преходом из флеша - к ссылке добавляется имя сайта.

Форумы CMS Joomla Проблема с преходом из флеша - к ссылке добавляется имя сайта.

pro3dlife
8 лет
0
Проблема с преходом из флеша - к ссылке добавляется имя сайта.

На новом хостинге столкнулся с такой проблемой. Я создаю виртуальный туры во флеше. Внутри флеша есть переход по ссылке. Но, почему-то при нажатиина ссылку открывается новое окно не ссылки, а к указанному урл добавляется еще имя моего сайта. Естественно ничего не переходит.
Вот, например виртуальный тур http://www.vr-photo.com.ua/images/pan...
И там на лого справа внизу переход на сайт voentorg.org. А фактически вылетает урл http://www.vr-photo.com.ua/images/pan... и ничего никуда не переходит.
вот строчка из xml
<plugin name="logo4" url="voentorg_disidata/graphics/logo4.png" keep="true" align="rightbottom" x="10" y="10" width="160" height="40" onclick="openurl(http://www.voentorg.org,_blank)"/>
Подскажите, в чем проблема?

rudenko
8 лет
0

Flash выполняется то не на хостинге, а на клиентском компьютере. И подает команду браузеру клиента сделать переход.
Сервер тут участвет только в отдаче swf файла клиенту, без всякой дополнительной обработки.
Тут проблему не в хостинге искать нужно а во flash ролике.
Нужно сделать trace параметра, который передается непосредственно в ролик.

pro3dlife
8 лет
0

А как быть с таким моментом - при запуске ролика с компьютера все работает верно- ролик открываю в модзилле, нажимаю на переход и все открывается верно.
А если этот же ролик запускаю с сайта, то получаю неверный переход

rudenko
8 лет
0

Такое ощущение, что в качестве параметра передается не http://www.voentorg.org, а просто www.voentorg.org. Попробуйте вывести отладочную информацию для ролика с указанием строки, которая передается непосредственно в функцию, которая должна открывать новое окно с ссылкой.

pro3dlife
8 лет
0

Да нет, все полностью прописываю.
Я вот подумал - может у меня модзилла глючит? Можете попробовать сами сделать переход по ссылке?

rudenko
8 лет
0

У меня в chrome под Linux та же проблема.

pro3dlife
8 лет
0

если не сложно, попробуйте еще раз проверить

rudenko
8 лет
0

О, теперь работает нормально. В новом окне открывает ссылку.

Участвовать в общении на этом форуме могут только зарегистрированные пользователи.