We use cookies
We use cookies to optimize our website. By continuing to browse the site, you agree to our use of cookies.
New design
Control panel
  • Русский
  • Українська
  • English
  • UAH
  • USD
  • RUB
  • EUR
  • 0-800-307-307 Hotline
  • +38 (044) 392-74-33 Kiev
  • +38 (057) 728-39-00 Kharkiv
  • +38 (056) 794-38-31 Dnipro
  • +38 (032) 229-58-93 Lviv
  • +38 (048) 738-57-70 Odessa
  • +38(093) 170-15-42  Life
  • +38 (067) 400-88-44 Kievstar
  • +1(888)393-24-51  USA, Toll free
  • +44(131)507-01-14  Great Britain
  • +7 (499) 348-28-61 Moscow

CMS Joomla. Ошибка ...plugins/content/fbdiscussbot.php on line 336

alexandr1.p
8 years old
0

Подскажите пожалуйста, как устранить данную ошибку - Notice: Undefined property: stdClass::$state in /home/mebelid/mebelid.com.ua/www/plugins/content/fbdiscussbot.php on line 336

toxi
8 years old
0

Скорее всего плагин, который вы установили, не подходит для вашей версии Joomla.
Попробуйте найти плагин мамбота fbdiscussbot той версии, которая совместима с установленной Joomla.

alexandr1.p
8 years old
0

Дело в том, что открывая этот сайт на localhost, этой ошибки нет, но на хосте уже есть - может, изменения произошли уже в настройках? Перезаливать сайт не хотелось бы, так как много уже было исправлено ошибок. Может есть у кого-то идеи что нужно сделать? Спасибо.
Этот файл уже перезаливал, ошибка не исчезла.

Евгений В.
8 years old
0

А версия PHP какая стоит сейчас? Если 5.3 - попробуйте 5.2 установить
https://www.ukraine.com.ua/faq/Kak-sm...

alexandr1.p
8 years old
0

У меня стоит версия PHP 5.2, Joomla 1.5.7. Перелопатил кучу форумов - результат "0". Если бы он не работал изначально, другой вопрос - проблема с совместимостью плагина с Joomla, но ведь изначально эта ошибка не возникала. Попробую любые предложения. Спасибо.

lavrik_av
8 years old
0

Вот же написали:
"А версия PHP какая стоит сейчас? Если 5.3 - попробуйте 5.2 установить"

Т.е. зайди в Joomla Admin panel -> System Information и посмотри версию PHP в своем аккаунте. Скорее всего, ты обнаружишь, что ukraine.com.ua предоставил PHP v 5.3.21. В этом случае, тебе нужно будет в настройках своего аккаунта выбрать PHP 5.2, или попроси в Службе поддержки сделать это.

alexandr1.p
8 years old
0

Прошу меня извинить если я не правильно Вас понимаю, но повторюсь: "в Joomla Admin panel -> System Information и посмотри версию PHP в своем аккаунте" - там стоит версия PHP Version 5.2.17, на хосте ukraine.com.ua включена версия - PHP 5.2.

Платформа: Linux web76.ukraine.com.ua 2.6.32-279.19.1.el6.x86_64 #1 SMP Wed Dec 19 07:05:20 UTC 2012 x86_64
Версия MySQL: 5.1.61-cll
Сравнение БД: utf8_general_ci
Версия PHP: 5.2.17
Вэб-сервер: Apache
Интерфейс вэб-сервер -> PHP: cgi-fcgi
Версия Joomla: Joomla! 1.5.7 Production/Stable [ Wovusani ] 9-September-2008 23:00 GMT
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17
В настройках аккаунта выбран PHP 5.2
Жду ваших идей, заранее спасибо за любую!

toxi
8 years old
0

Есть предложение попробовать оригинальный дистибутив, вместо сборки. Насколько я понял из названия ( Joomla! 1.5.7 Production/Stable [ Wovusani ] ), то у вас установлена сборка. Хотя могу ошибаться.
Ещё есть вариант, изменить версию PHP. А на некоторых форумах рекомендуют отключить вывод ошибок PHP, если всё работает и просто эта ошибка портит дизайн.

alexandr1.p
8 years old
0

Так как эта ошибка не влияет на работу сайта, я воспользовался советом "toxi" и просто отключил вывод этой ошибки. Если кому-то понадобится сделать тоже самое, то можно сделать следующее:
ИЗМЕНЕНИЕ ПАРАМЕТРА ERROR_REPORTING В PHP.INI
Изменить уровень вывода ошибок можно в файле php.ini (конфигурационный файл PHP). Для этого необходимо найти в файле php.ini параметр error_reporting и установить значение E_ERROR. Например вот так:


error_reporting = E_ERROR
Это будет выглядеть у Вас в строке после изменения вот так:
var $error_reporting = 'E_ERROR';

lavrik_av
8 years old
0

Joomla! 1.5.7 - Не совсем понимаю, а смысл пытаться реанимировать такой "древний" продукт?
Просто интересно?

The topic is closed.